[silva-dev] Update - silva2odt

Reinhard Hess reinhard.hess at id.ethz.ch
Sat Jun 23 18:51:41 CEST 2007


Dave Kuhlman wrote:
> On Thu, Jun 21, 2007 at 11:38:19PM +0200, Marc Petitmermet wrote:
>> dear dave
>> 
>> first: thank you very much for the great work you are doing here. i
>>  downloaded and installed silva2odt and gave it a try. however, i
>>  could not get it working at all. but this might be due to not
>> using the correct versions of the required programs. could you
>> please tell me what are the minimal required versions for python,
>> lxml and silva?
>> 
> 
> Marc -
> 
> Thanks for feedback.
> 
> I'm using:
> 
> - Python 2.5.1
> 
> - lxml-1.2.1
> 
> - Silva from SVN
> 
> I believe that, in silva2odt.py itself, everything other than lxml 
> comes from the Python standard library.  And, by the way, I check my
> results in OpenOffice 2.2.
> 
> I do not know what kind or error you are getting.  Is it an import 
> error?  Or, does it seem to be having trouble with the input file 
> (silva.xml or the file that contains it)?  Do you get a traceback?
> 
> I've placed a zip file containing two archives exported from Silva 
> which I've used in my testing.  Could you please let me know what 
> kind of error you get when you process one of these files.  You can 
> find that file here:
> 
> http://www.rexx.com/~dkuhlman/silva2odt_data.zip
> 
> You should be able to use it as follows:
> 
> $ unzip silva2odt_data.zip $ silva2odt.py -z
> folder1_export_2007-06-12.zip folder1.zip $ silva2odt.py
> doc3-1_export_2007-06-15.zip
> 
> Dave
> 

Hi,

I followed the anouncement and the discussion. It seemed to be interesting.
Now, in a production environment and especially in a larger production 
environment there are very reasonable restrictions in regard to the 
version of usable software. We can only use the versions which are 
officially supported by Infrae, for obvious reasons.
Now I wonder, wether it makes sense at all for us to consider a use of 
that otherwise nice tool:
We cannot use Silva from svn (which branch? 2.0? 1.5? 1.6). Especially 
if we would have to use Silva-2.0 it is no option for us. Is Silva-1.6 a 
candidate for that tool?

Greetings,
Reinhard

-- 
Reinhard Hess
Email: reinhard.hess at id.ethz.ch
Phone: +41-(0)44-632 30 86
Fax:   +41-(0)44-632 13 12
ETH Zuerich
Informatikdienste / Arbeitsplatzinformatik
WEP J 17.1
Weinbergstrasse 109
CH-8092 Zuerich



More information about the silva-dev mailing list