[Silva-general] problems installing via buildout

bdsilva at knowledgeworks.plus.com bdsilva at knowledgeworks.plus.com
Sat Nov 28 16:59:58 CET 2009


Kit Blake wrote:

>Buildout is the way to go, although it brings another learning curve.
>Well worth it if you continue with anything Zope. See:
>http://docs.infrae.com/silva/buildout.html#installing-silva-from-svn-for-development-or-production

I tried the instructions referenced above.  However the buildout appears
to have failed.  But I can't see that I did anything wrong, as the
instructions in the above URL are very clear.  When the buildout finished,
the ./bin directory did not contain any instance (it just contains the
buildout script).

This was running on OpenSuse 10.3, with Python 2.4.5.  Obviously I'm new
to buildout, so maybe I did something wrong.  However, this was all done
on the same server where I already have Zope 2.11.1 and Python 2.4.5
running with Silva from Silva-2.1.3-all.tgz, so I would expect it to meet
any requirements for the buildout.

I ran the buildout again, and collected the stdout & stderr. Here are
sample lines that may be relevant (i.e. that contain errors or warnings):

warning: no previously-included files found matching '*.orig'
...
  File
"/home/zopista/silva.svn/Silva/eggs/tmpBX94-f/Zope2-2.12.1-py2.4-linux-i686.egg/Zope2/Startup/zopectl.py"
, line 313
    finally:
          ^
SyntaxError: invalid syntax
...
  File
"build/bdist.linux-i686/egg/RestrictedPython/tests/security_in_syntax26.py",
line 6
    with x as _leading_underscore:
         ^
SyntaxError: invalid syntax

Getting distribution for 'Acquisition'.
src/Acquisition/_Acquisition.c:44:1: warning: "FORMAT_N" redefined
src/Acquisition/_Acquisition.c:34:1: warning: this is the location of the
previous definition
...
no previously-included directories found matching 'docs-in-progress'
  File "build/bdist.linux-i686/egg/mechanize/_firefox3cookiejar.py", line 91
    yield row
SyntaxError: 'yield' not allowed in a 'try' block with a 'finally' clause

and the final three lines of the buildout log are:

Compiling python modules
Creating fake eggs
Installing silva-all.

Please let me know if you would like the entire log.

Regards, Bernard




More information about the silva-general mailing list