[Silva-general] Bad constraint 0.6c11 setuptools>=0.7 when trying to install Silva 3.0.2

Josef Meile jmeile at hotmail.com
Fri Jul 19 20:03:30 CEST 2013


Hi,

I'm trying to install Silva 3.0.2 under Debian Squeeze according this
instructions:
http://docs.silvacms.org/3.0/buildout.html

1) First at all, I did a fresh install of python 2.7.5 and zope 2.13.21. I'm
not using binary packages from debian and Zope is up and running.
2) I already had: zlib + headers, libjpeg + headers.
3) I installed PIL 1.1.7 with JPEG, PNG, and OpenType/TrueType. The PIL
installation successfully detected the libraries.
4) I also installed libXML2 and libXSLT + headers

Then I tried the Silva installation:
svn co https://svn.infrae.com/buildout/silva/tag/Silva-3.0.2 Silva
cd Silva
/usr/local/zope/2.13.21/bin/python2.7 bootstrap.py --buildout-profile
profiles/simple-instance.cfg
./bin/buildout

But I'm getting the error message at the end of this message, which tells
basically: " Error: Bad constraint 0.6c11 setuptools>=0.7"

So, after that, I tried upgrading setuptools to 0.9.0:
wget https://bitbucket.org/pypa/setuptools/downloads/ez_setup.py -O - |
/usr/local/zope/2.13.21/bin/python

Then I deleted deleted the previous Silva folder and downloaded it again
from svn. But I'm still getting the error message.

When I checked the setuptools version like this:
/usr/local/zope/2.13.21/bin/python2.7
Python 2.7.5 (default, Jul 19 2013, 16:41:17)
[GCC 4.4.5] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import setuptools
>>> setuptools.__version__
'0.9.6'

As you see, the version reported by python is 0.9.6, so, I don't know what's
the problem here. What else can I try?

The first line of bin/buildout contains:
#!/usr/local/zope/2.13.21/bin/python2.7

So, the right python binary is being used.

Thanks in advanced.

Best regards
Josef


ERROR MESSAGE
------------------------
Link to
http://bitbucket.org/tarek/distribute/get/0.6-maintenance.zip#egg=distribute
-dev ***BLOCKED*** by --allow-hosts

Getting distribution for 'distribute'.
warning: install_lib: 'build/lib' does not exist -- no Python modules to
install

Got distribute 0.7.3.
The constraint, 0.6c11, is not consistent with the requirement,
'setuptools>=0.7'.
While:
  Installing.
  Checking for upgrades.
Error: Bad constraint 0.6c11 setuptools>=0.7



More information about the silva-general mailing list