[Silva-general] Bad constraint 0.6c11 setuptools>=0.7 when trying to install Silva 3.0.2

Josef Meile jmeile at hotmail.com
Fri Jul 19 21:13:25 CEST 2013


Hi again

First at all, I must say that I remove all setuptools* files from system and
tried again installing version 0.9.6. I haven't any distribute* files. It
didn't work; I still got the same error.

Then I deleted again all the setuptools* file and tried to install an older
version:
wget https://bitbucket.org/pypa/setuptools/raw/0.7.8/ez_setup.py -O - |
python

I checked again the version in the python command and it was: "0.7.8", so, I
proceed again with the installation, but it failed when configuring the
bootstrap. Now it showed:
/usr/local/zope/2.13.21/bin/python2.7 bootstrap.py --buildout-profile
profiles/simple-instance.cfg

Downloading
http://pypi.python.org/packages/source/d/distribute/distribute-0.6.40.tar.gz
Extracting in /tmp/tmp7qayo_
Now working in /tmp/tmp7qayo_/distribute-0.6.40
Building a Distribute egg in /tmp/tmpVC7FM8
Traceback (most recent call last):
  File "setup.py", line 45, in <module>
    exec(init_file.read(), d)
  File "<string>", line 8, in <module>
  File "/tmp/tmp7qayo_/distribute-0.6.40/setuptools/__init__.py", line 2, in
<module>
    from setuptools.extension import Extension, Library
  File "/tmp/tmp7qayo_/distribute-0.6.40/setuptools/extension.py", line 5,
in <module>
    from setuptools.dist import _get_unpatched
  File "/tmp/tmp7qayo_/distribute-0.6.40/setuptools/dist.py", line 6, in
<module>
    from setuptools.command.install import install
  File "/tmp/tmp7qayo_/distribute-0.6.40/setuptools/command/__init__.py",
line 8, in <module>
    from setuptools.command import install_scripts
  File
"/tmp/tmp7qayo_/distribute-0.6.40/setuptools/command/install_scripts.py",
line 3, in <module>
    from pkg_resources import Distribution, PathMetadata, ensure_directory
  File "/tmp/tmp7qayo_/distribute-0.6.40/pkg_resources.py", line 2841, in
<module>
    add_activation_listener(lambda dist: dist.activate())
  File "/tmp/tmp7qayo_/distribute-0.6.40/pkg_resources.py", line 710, in
subscribe
    callback(dist)
  File "/tmp/tmp7qayo_/distribute-0.6.40/pkg_resources.py", line 2841, in
<lambda>
    add_activation_listener(lambda dist: dist.activate())
  File "/tmp/tmp7qayo_/distribute-0.6.40/pkg_resources.py", line 2273, in
activate
    self.insert_on(path)
  File "/tmp/tmp7qayo_/distribute-0.6.40/pkg_resources.py", line 2374, in
insert_on
    "with distribute. Found one at %s" % str(self.location))
ValueError: A 0.7-series setuptools cannot be installed with distribute.
Found one at
/usr/local/zope/2.13.21/lib/python2.7/site-packages/setuptools-0.7.8-py2.7.e
gg
/tmp/tmpVC7FM8/distribute-0.6.40-py2.7.egg
Traceback (most recent call last):
  File "bootstrap.py", line 59, in <module>
    ez['use_setuptools'](**ez_options)
  File "<string>", line 152, in use_setuptools
  File "<string>", line 132, in _do_download
  File "<string>", line 123, in _build_egg
IOError: Could not build the egg.

So, neither the old nor the new version of setuptools works. Is there any
other way of installing silva?

Best regards
Josef

-----Ursprüngliche Nachricht-----
Von: Josef Meile [mailto:jmeile at hotmail.com] 
Gesendet: Freitag, 19. Juli 2013 20:04
An: 'silva-general at lists.infrae.com'
Betreff: Bad constraint 0.6c11 setuptools>=0.7 when trying to install Silva
3.0.2

Hi,

I’m trying to install Silva 3.0.2 under Debian Squeeze according this
instructions:
http://docs.silvacms.org/3.0/buildout.html

1) First at all, I did a fresh install of python 2.7.5 and zope 2.13.21. I’m
not using binary packages from debian and Zope is up and running.
2) I already had: zlib + headers, libjpeg + headers.
3) I installed PIL 1.1.7 with JPEG, PNG, and OpenType/TrueType. The PIL
installation successfully detected the libraries.
4) I also installed libXML2 and libXSLT + headers

Then I tried the Silva installation:
svn co https://svn.infrae.com/buildout/silva/tag/Silva-3.0.2 Silva cd Silva
/usr/local/zope/2.13.21/bin/python2.7 bootstrap.py --buildout-profile
profiles/simple-instance.cfg ./bin/buildout

But I’m getting the error message at the end of this message, which tells
basically: " Error: Bad constraint 0.6c11 setuptools>=0.7"

So, after that, I tried upgrading setuptools to 0.9.0:
wget https://bitbucket.org/pypa/setuptools/downloads/ez_setup.py -O - |
/usr/local/zope/2.13.21/bin/python

Then I deleted deleted the previous Silva folder and downloaded it again
from svn. But I'm still getting the error message.

When I checked the setuptools version like this:
/usr/local/zope/2.13.21/bin/python2.7
Python 2.7.5 (default, Jul 19 2013, 16:41:17) [GCC 4.4.5] on linux2 Type
"help", "copyright", "credits" or "license" for more information.
>>> import setuptools
>>> setuptools.__version__
'0.9.6'

As you see, the version reported by python is 0.9.6, so, I don't know what's
the problem here. What else can I try?

The first line of bin/buildout contains:
#!/usr/local/zope/2.13.21/bin/python2.7

So, the right python binary is being used.

Thanks in advanced.

Best regards
Josef


ERROR MESSAGE
------------------------
Link to
http://bitbucket.org/tarek/distribute/get/0.6-maintenance.zip#egg=distribute
-dev ***BLOCKED*** by --allow-hosts

Getting distribution for 'distribute'.
warning: install_lib: 'build/lib' does not exist -- no Python modules to
install

Got distribute 0.7.3.
The constraint, 0.6c11, is not consistent with the requirement,
'setuptools>=0.7'.
While:
  Installing.
  Checking for upgrades.
Error: Bad constraint 0.6c11 setuptools>=0.7



More information about the silva-general mailing list