[Silva-general] Bad constraint 0.6c11 setuptools>=0.7 when trying to install Silva 3.0.2

Sylvain Viollon sylvain at infrae.com
Mon Jul 22 10:47:34 CEST 2013


Op 20 jul 2013, om 09:18 heeft Josef Meile het volgende geschreven:

> Hi,
> 

   Hello,

> Somehow, I think this must be a bug in the installer. I had to delete the
> only dependency on the distribute egg, which was "setuptools>=0.7", from
> this file:
> # /tmp/Silva/eggs/distribute-0.7.3-py2.7.egg/EGG-INFO/requires.txt
> 
> After that I run
> # ./bin/buildout
> 
> And on the output I saw:
> 
> #  Getting distribution for 'setuptools==0.6c11'.
> #  Got setuptools 0.6c11.
> 
> So, why is the installer getting setuptools 0.6c11, when it is supposed to
> be greater than 0.7?
> 
> Anyway, the workaround worked, but I think this must be fixed.
> 
> One question more: I installed all from /tmp/Silva. So, now I figured out
> that this was a bad option. It seems that you don't really need zope to
> install silva. Silva has its own zope. It is any way of working with my own
> zope? 
> 
> By the way, it would be nice if the silva installation also ask you for a
> username and password for your admin. That's the way zope does it.
> 

   People managing setuptools released a new version that breaks about
every buildout user on Earth.

   You can edit the file buildout.cfg and add:

   [versions]
   zc.buildout = 2.2.0-infrae1

   A new release with this fix is scheduled in the coming month.

   Regarding the password, yet again buildout doesn't give us this
possibilities like did the old Zope tools. So we picked admin/admin
by default and users can change it after in Zope.

   We are a bit tired as well of the endless bugs with buildout/setuptools
and the lack of flexibility at the some level and will be moving to a
better system soon we hope.

   Regards,

   Sylvain,


-- 
Sylvain Viollon -- Infrae
t +31 10 243 7051 -- http://infrae.com
Hoevestraat 10 3033GC Rotterdam -- The Netherlands





More information about the silva-general mailing list