[Silva-general] LDAPUserFolder-2.26 / Silva-2.2 / LDAPDelegate Too many results / SIZELIMIT_EXCEEDED / OverflowError

Sylvain Viollon sylvain at infrae.com
Fri Jul 26 10:58:30 CEST 2013


Op 26 jul 2013, om 08:24 heeft Richard Mahoney het volgende geschreven:

> Thank you Sylvain,
> 

Hello,

> I tried to install silva.pas.base with Silva 2.2 using buildout and constantly came up against issues with incompatible Python Package versions so couldn't get the buildout to complete.
> 

   You can use this buildout as a starting point for buildout: https://svn.infrae.com/buildout/silva/tag/Silva-2.2.1
It is very important that if you add silva.pas.base in it, you fix its version to 1.5.5 (the one I recommended you),
otherwise you will the latest version that only work in Silva 3.0 (and the dependencies with the Silva 3.0
versions). To do this in buildout.cfg you can add:

   [versions]
   silva.pas.base = 1.5.5

> I've decided that the best thing to do is to upgrade Silva from 2.2 to 2.3.7 using svn and buildout (silva.pas.base seems to be included in the 2.3 release). The upgrade with buildout completed without issue but I'm getting an error with zodbupdate:
> 
> ./bin/zodbupdate -f var/filestorage/Data.fs
> 
> Traceback (most recent call last):
>  File "./bin/zodbupdate", line 209, in ?
>    import zodbupdate.main
>  File "/home/ieb/zope3/Silva-2.2/eggs/zodbupdate-0.5-py2.4.egg/zodbupdate/main.py", line 24, in ?
>    import zodbupdate.update
>  File "/home/ieb/zope3/Silva-2.2/eggs/zodbupdate-0.5-py2.4.egg/zodbupdate/update.py", line 23, in ?
>    import zodbupdate.serialize
>  File "/home/ieb/zope3/Silva-2.2/eggs/zodbupdate-0.5-py2.4.egg/zodbupdate/serialize.py", line 165
>    symb = find_global(*symb_info, Broken=ZODBBroken)
> 
> At this point the Data.fs file doesn't appear to have been altered.
> 
> I'm not sure what is happening here and would be grateful for any suggestions.
> 

    Could you paste me the error as well (the line after the traceback), I am not sure what is the problem
here. If your Data.fs is old I recommend you to run:

    ./bin/zodbupdate -p Python -f var/filestorage/Data.fs

    This will get ride of a Zope hack that was in Python and got removed in Python 2.6.

    Regards,

    Sylvain,

-- 
Sylvain Viollon -- Infrae
t +31 10 243 7051 -- http://infrae.com
Hoevestraat 10 3033GC Rotterdam -- The Netherlands





More information about the silva-general mailing list